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Outline
What we are going to talk about today

• CARTA basics


• Tutorials


• How to load images


• How to render images


• How to match images


• Image analytics


• Polarization cube visualization and analysis


• Catalog visualization


• GUI customization

• Region of interest and 
statistics


• Spatial profile


• Spectral profile


• Profile smoothing


• Spectral profile fitting


• Moment map generator


• PV map generator


• Spectral line ID


• Rest frequency shifting



Test images

http://bit.ly/3RQkPO1

Unzipped size ~ 500 MB

http://bit.ly/3RQkPO1


CARTA basics



CARTA
Cube Analysis and Rendering Tool for Astronomy

• A new generation image visualization and analysis tool designed for 


• ALMA, VLA, and SKA pathfinders (MeerKAT and ASKAP)


• future telescopes such as ngVLA and SKA.


• Support terabyte-scale image cubes


• Provide easy-to-use, efficient, and feature-rich user interfaces (GUI and CLI)


• Observing/grant proposal preparation


• General image analysis


• Science presentation and publication


• To support collaborative tools over internet



Overview
CARTA development team

• Membership of the CARTA development project


• ASIAA 
Academia Sinica, Institute of Astronomy and 
Astrophysics


• IDIA 
Inter-University Institute for Data Intensive 
Astronomy


• NRAO 
National Radio Astronomy Observatory


• Dept. of Physics, University of Alberta


• Team scale: ~20 people including dev, science, and 
management teams currently



Overview
CARTA releases

• Project reboot: March 2018


• CARTA v1.0 release: December 2018


• Targeting one beta release and one 
stable release every 9-month 
development cycle


• Upcoming: 


• v4.0-stable (~ August 2023)


• Obtain CARTA via https://cartavis.org

Latest stable release

Latest beta release

v3.0

v4.0-beta

https://cartavis.org


Overview
CARTA architecture: Client-Server

See https://cartavis.org for a list of adopted libraries 
See https://github.com/CARTAvis for the CARTA codebase


See https://carta-controller.readthedocs.io/en/latest/ for server deployment

Client Server

WebSocket

Data stream with just sufficient 
accuracy for visualization


(Latency hiding techniques)

Your (really) BIG DATA here

Processed small(er) data here for 
client-side GPU-accelerated rendering

https://cartavis.org
https://github.com/CARTAvis
https://carta-controller.readthedocs.io/en/latest/


Overview
CARTA deployment modes

User Deployment Mode (UDM) 
Ideal for a single user with a local computer or a remote server

Site Deployment Mode (SDM) 
Ideal for institute-wide deployment to support multiple 
users with a shared file system and collaborative work

VNC

ssh 
carta --no_browser

[2022-02-15 10:57:50.230] [CARTA] [info] CARTA is accessible at http://
localhost:3002/?token=10E3735B-3E42-43C1-A1E5-3B324885B0F6

carta 
(or click app icon) https://carta.xxx.yyy

Check the controller user manual 
https://carta-controller.readthedocs.io/en/latest/

Or contact support@carta.freshdesk.com for help

Don’t!

http://localhost:3002/?token=10E3735B-3E42-43C1-A1E5-3B324885B0F6
http://localhost:3002/?token=10E3735B-3E42-43C1-A1E5-3B324885B0F6
http://localhost:3002/?token=10E3735B-3E42-43C1-A1E5-3B324885B0F6
https://carta.xxx.yyy
https://carta-controller.readthedocs.io/en/latest/
mailto:support@carta.freshdesk.com


ALMA Science Archive Deployment
Overview

• ALMA news on March 24, 2021 
https://almascience.nrao.edu/
news/alma-science-archive-
remote-visualization-with-carta


• v3.0 is online now

https://almascience.nrao.edu/news/alma-science-archive-remote-visualization-with-carta
https://almascience.nrao.edu/news/alma-science-archive-remote-visualization-with-carta
https://almascience.nrao.edu/news/alma-science-archive-remote-visualization-with-carta


Overview
CARTA info

• Homepage 
https://cartavis.org


• User manual 
https://carta.readthedocs.io/en/latest


• Controller user manual (for site deployment) 
https://carta-controller.readthedocs.io/en/
latest/


• Helpdesk 
Email to support@carta.freshdesk.com


• Codebase 
https://github.com/CARTAvis

https://cartavis.org
https://carta.readthedocs.io/en/latest/
https://carta-controller.readthedocs.io/en/latest/
https://carta-controller.readthedocs.io/en/latest/
mailto:support@carta.freshdesk.com
https://github.com/CARTAvis


Tutorials



Test images

http://bit.ly/3RQkPO1

Unzipped size ~ 500 MB

http://bit.ly/3RQkPO1


How to load images
Graphical user interface (GUI) v.s. commendline user interface (CLI)

• Supported format: FITS, CASA, HDF5-
IDIA, MIRIAD


• GUI


• “File -> Open image” 
(close existing images first)


• “File -> Append image” 
(without closing existing images)


• Flexible file filtering modes


• Multi-selection (macOS: CMD+click, 
Linux: CTRL+click) to load multiple 
images at once


• Load a “computed” image via “lattice 
expression language” (LEL)
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How to load images
Graphical user interface (GUI) v.s. commendline user interface (CLI)

• CLI


• macOS electron app: in .zshrc, set up an alias as 
alias carta=‘/Applications/CARTA.app/Contents/MacOS/CARTA’ 
Then in terminal 
carta a.fits

• macOS homebrew installation: 
carta a.fits


• Linux: 
./carta.AppImage a.fits (may also set up an alias too) 
carta a.fits (installation via a package manager like apt or dnf)


• URL query parameter (useful for workflow integration) 
http://localhost:3002/?file=a.fits  
http://localhost:3002/?files=[a.fits,b.fits]

http://localhost:3002/?file=a.fits
localhost:3002/?files=%5Ba.fits,b.fits%5D


How to render images
Raster image rendering

• By default, images are rendered 
as raster


• Per-channel clip range as 
default


• Use render configuration widget 
to modify raster rendering


• Raster rendering:


• GPU-accelerated (WebGL2)


• Tile-based, multi-resolution
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How to render images
Contour image rendering

• Use contour configuration dialog for 
contour rendering


• Flexible 


• Level definition


• Smoothing scheme


• Styling


• Contour rendering:


• GPU-accelerated (WebGL2)


• Contour vertices are computed in 
parallel 



How to match images
Spatial matching

• Multiple images can be matched 
spatially so image panning and 
zooming are synchronized.


• Use the image list widget to 
perform image matching


• Matched images share their


• contour / vector field / catalog 
rendering


• region set


• Reference image v.s. secondary 
images



How to match images
Spatial matching and spectral matching

• Multiple image cubes can be matched 
spatially and spectrally so image 
panning and zooming are 
synchronized and channel switching is 
also synchronized


• Use the image list widget to perform 
image matching


• Spectral matching adopts nearest 
interpolation 


• Reference image v.s. secondary 
images


• Use the animator widget for channel 
navigation



Exercise 1/4
• Try to load images in CARTA 

• Use any of the test images


• Try to change the appearance of your raster images 

• Use any of the test images


• Try to configure and render contours 

• Use any of the test images


• Try to match your raster and contour images 

• Use images in Gaussian_array


• Use images in HD163296 folder



Image analytics
Region of interest and statistics

• Region of interest can be created via 


• the region bar at the top of the GUI


• the tool bar in the image viewer


• Region of interest can be exported as a text 
file in CASA (.crtf) or ds9 (.reg) format


• The region list widget summarize all region 
properties


• The statistics widget reports region 
statistics


• “Active” image and “active” region


• Flexible image, region, and polarization 
configuration 



Image analytics
Spatial profile

• The spatial profile widget displays 
a spatial profile from


• Cursor and point region (treated 
as a horizontal or a vertical cut)


• Line region


• Polyline region


• The averaging width is configurable 
in the settings dialog


• Projection distortion is considered 
when the offset or distance is 
calculated



Image analytics
Spectral profile

• The spectral profiler widget 
displays spectral profiles


• from different images


• from different regions


• with different statistics


• from different polarization 
components


• Channel navigation can also be 
performed with the profiler plot
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Image analytics
Profile smoothing

• Profile smoothing can be 
applied to spatial profiles or 
spectral profiles to enhance 
the S/N


• Various smoothing 
schemes are supported



Image analytics
Spectral profile fitting

• Multiple Gaussian or Lorentzian 
profiles are supported with an 
optional 0th or 1st order continuum.


• Flexible initial guess configuration


• Smart guess!


• Profile data in the view are the input 
data for the smart guess and fitting


• If profile smoothing has been 
applied, smoothed profile is the 
input data for fitting



Image analytics
Image fitting

• Multiple-Gaussian 
components can be fitted


• Optionally, fitting 
parameters can be locked


• Model and residual images 
are generated and 
appended after fitting


• Elliptical regions can be 
created based on the 
fitting results

New features are available in v4-beta



Exercise 2/4
• Try to visualize a spatial profile from a line or a polyline region 

• Use any of the test images


• Try to visualize spectral profiles from multiple matched images 

• Use images in HD163296 folder


• Try to visualize spectral profiles from different regions of an image 

• Use images in HD163296 folder or S255 folder


• Try to smooth a spatial or a spectral profile 

• Use images in HD163296 folder or S255 folder


• Try to fit Gaussians to a spectral profile 

• Use images in HD163296 folder or S255 folder



Image analytics
Moment map generator

• The moment generator can 
produce a set of “moment” 
images as defined in CASA


• Generated moment images are 
automatically appended.


• Moment images may serve as 
a guide map for spectral 
profile exploration


• May save a generated moment 
image via “File -> Save image”



Image analytics
PV map generator

• The PV map generator extracts a 
slice from an image cube along a 
line region (offset v.s. velocity)


• The generated PV image is 
automatically appended


• May save a PV image via “File -> 
Save image”


• Spectral convention can be 
changed with the image view 
settings dialog 


• Projection distortion is considered 
when the offset axis is computed

New features are available in v4-beta



Image analytics
PV map generator - interactive preview

• A scalable version of 
KARMA-kpvslice is 
implemented in v4-beta


• A downsampled cube 
can be created for PV 
preview purpose


• By dragging the PV cut, 
the PV preview image is 
rendered in the PV 
preview widget

New in v4-beta



Image analytics
Spectral line ID

• Spectral line IDs from the Splatalogue 
(https://splatalogue.online/) can be over 
plotted on a spectrum for line 
identification


• In this special use case, we need to 
match the cubes in “frequency” via the 
settings dialog of the image list widget 
in order to compare images


• Use the line table to filter and select 
target lines/species for ID overplotting 


• Future enhancement


• Offline database


• Automatic line identification



Image analytics
Rest frequency shifting

• Frequency to velocity 
conversion depends on the 
RESTFRQ header


• The RESTFRQ header of 
each loaded image can be 
temporarily modified via the 
image list widget to enable a 
new conversion for line 
matching


• This applies to the spectral 
axis of the PV image too



Exercise 3/4
• Try to generate some moment images 

• Use images in HD163296 folder or S255 folder


• Try to generate a PV image 

• Use images in HD163296 folder or S255 folder


• Try to label spectral line IDs 

• Use images in S255 folder (try CH3CN at ~4 km/s)


• Use images in G31.41p0.31_bandscan folder (try C2H5OH “beer!” 🍺 ) 
at ~98 km/s)


• Try to match spectral lines in the velocity space by setting new rest 
frequencies 

• Use images in S255 folder and match  
CH3CN J19-18 K=3 at 349393.2971 GHz 
NH2CHO 16(2,14)-15(2,13) at 349479.5473 MHz



Polarization cube visualization and analysis
Stokes analysis widget and computed polarization components

• When a Stokes cube is loaded, 
a set of plots is generated in 
the Stokes analysis widget


• Q v.s. U profile and scatter 
plot (Faraday rotation)


• Pol. I and Pol. A profiles


• Use the animator to switch to 
different Stokes (native) and 
other (on-the-fly) computed 
components 



Polarization cube visualization and analysis
Vector field rendering

• A linear polarization field can be 
computed and rendered from a 
Stokes cube


• A linear polarization angle field can 
be rendered from a pre-calculated 
image


• An optional angle offset can be 
applied (e.g., +90 deg to infer B-
field)


• A scalar field can also be rendered


• Matched images share their vector 
field rendering



Polarization cube visualization and analysis
Forming a Stokes hypercube

• If Stokes I, Q, U, and V are as 
individual files, you can use the file 
browser to form a Stokes hypercube 
and treat the result as a single (virtual) 
file


• Perform analysis with


• animator


• Stokes analysis widget


• Spectral profiler widget


• Vector field rendering dialog


• …



Catalog visualization
Linked rendering

• Offline catalog (“File -> Import catalog”): 
FITS and VOTable format


• Online catalog query


• The catalog widget supports filtering


• Catalog can be rendered and inter-linked 
as


• Image overlay (GPU-accelerated, 
WebGL2)


• 2D scatter plot


• histogram


• Matched images share their catalog 
image overlay rendering



Catalog visualization
Marker-based catalog rendering

• Image overlay as column-
mapped markers


• Size mapping


• Color mapping


• Orientation mapping



GUI customization
Custom layouts and preferences

• A custom layout can be


• saved (“View -> Layouts -> Save layout”)


• reused (“View -> Layouts -> Existing 
layouts”)


• Use the preference dialog (“File -> 
Preferences”) to customize the GUI such as


• default layout


• default colormap for raster rendering


• region creation modes (center-to-corner or 
corner-to-corner)


• Image pan modes (drag-to-pan or click-to-
pan)


• and many many more!



Exercise 4/4 and Q&A
• Load a Stokes cube and explore its context with the Stokes 

analysis widget and the animator 

• Use images in IRCp10216_line_pol (Stokes analysis widget and 
animator)


• Use images in HL_Tau_pol (animator)


• Load a Stokes cube or a polarization angle image to render a 
polarization vector field 

• Use images in HL_Tau_pol or images in IRCp10216_line_pol


• Load a catalog file, filter the catalog, and rendering it as an 
catalog image overlay 

• Use images and the catalog in cosmos_field folder


• Explore the preferences dialog



Thank you~
We hope CARTA can make your life easier 😃

https://cartavis.org

Please contact support@carta.freshdesk.com for any questions/comments

Cite CARTA!

This project needs your support!

https://cartavis.org
mailto:support@carta.freshdesk.com

